Older versions of Internet Explorer are vulnerable to attacks such as POODLE or Sweet32. This is because they use SSL 3.0 and TLS 1.0, which are outdated security protocols. Microsoft no longer support these protocols, due to their security risk. From 7th August 2017 we will no longer support browsers that use these protocols either.

IMPORTANT:

To continue to access Glasscubes and ensure that your connection is as secure as possible you will need to upgrade your browser to the latest version of IE, or install another browser, before 7th August 2017. For the best experience we recommend that you install Chrome.

Updating your TLS settings in IE

If you have no option than to use an older version of IE it is possible to improve your browser's security, and continue to access Glasscubes, by changing the protocol that it uses.

To do that, open you browser and click on the icon highlighted below to access the browser settings.

Select 'Internet options' from the drop down menu. On the options pop up select the 'Advanced' tab.

Scroll down the list to the 'Security' section and uncheck the boxes beside 'Use SSL 3.0' and 'Use TLS 1.0'. Then check the boxes against 'Use TLS 1.1' and 'Use TLS 1.2'. Now click 'Apply' followed by 'OK'.

Your browser has now been updated. Glasscubes will now use the most secure connection available.

What will happen if I don't update my browser?

If you try to access Glasscubes after 7th August 2017 you will get one of the following errors display.

If you are using IE 9:

If you are using IE 10:

Did this answer your question?